ベストセラー人気 WordPress テーマTop 30 詳細

Cafe24でphpMyAdmin接続時「要求の処理エラーのエラーコード:200」エラーが発生した場合

Last Updated:2021年7月19日| コメントを残す
  • Naver ブログを共有する
  • Naver バンドに共有する
  • Facebook 共有する
  • Twitter 共有する
  • 카카오스토리공유하기

Cafe24は、セキュリティの問題にphpMyAdminサービスを終了しました。 したがって、DBに接続するためには、MySQLクライアントツールを手動でインストールする必要があります。 phpMyAdminをインストールして接続した時、「要求の処理エラーのエラーコード:200」エラーが発生し、接続が途切れる場合があります。 この場合の対処方法について説明します。

Cafe24でphpMyAdmin接続時「要求の処理エラーのエラーコード:200」エラーが発生した場合

Cafe24でphpMyAdmin接続時「要求の処理エラーのエラーコード:200」エラーが発生した場合

최근 Cafe24でデータベースに接続ことがありphpMyAdminをインストールした後に接続しようとしたら、上記の図のようなエラーが発生しました。

요청 처리 중 에러 발생
오류 코드: 200
에러 메시지: OK (rejected)
서버와의 연결이 끊긴 것 같다. 네트워크 연결 및 서버 상태를 확인하십시오.

このエラーは、PHPのバージョンが5.xの環境でphpMyAdminバージョンが合わなくて発生します。 phpMyAdmin 4.0.10.20のバージョンをダウンロードすると、問題が解決することができます。

しかし、私はphpMyAdminバージョンを下げるなんてphpMyAdminの接続ページでは、HTTP 500エラーが発生しました。

これに関連し Cafe24 文書を見てみるとPHP7.xバージョン利用の際には、最新バージョンのphpMyAdminをダウンロードしてインストールしてPHP5.xバージョン利用の際にはheidisqlクライアントツールをインストールすることを推奨しています。

(Cafe24でphpMyAdminサービスを終了した直後のマニュアルでは、PHP5.xバージョン利用時phpMyAdmin 4.0.10.20のバージョンをダウンロードしてインストールすることを案内しましたが、今ではheidisqlツールのインストールに変更されたようです。)

したがって、PHP 5.x環境を利用する場合 Cafe24 文書を参照してheidisqlツールをインストールしてDBに接続すると正常にデータベースにアクセスすることができます。

望ましい方法 - PHPのバージョンに変更

しかし、PHP 5.xのバージョンが低すぎる WordPressを運営するには不向きで、セキュリティの問題、パフォーマンスの問題など、さまざまな問題が発生することができます。 PHP 5.xを使用する場合、最新の WordPress バージョンに更新していないことがあります。 したがって PHPのバージョンを7.0以降(Cafe24では7.3を推奨)に変更することが望ましいします。

Cafe24の場合PHP 5.xからPHP 7.0に変更した場合、サイトが初期化されるので、 必ずデータとDBをダウンロードした後に行わなければなりませ。 変更申請の際に、データとDBをダウンロードする必要があるという警告が表示されます。 そのような場合を無視して、バックアップせずにPHP変更申請すると、バックアップされたデータが存在しない場合、サイトを復元することができなくなって永久的にサイトが消えます。

Cafe24でPHPのバージョンを変更する方法は次の記事を参照してください。

PHPの変更申請後30分経過すると、変更が完了します。 これにより、バックアップされたデータとDBを持っているサイトを復元することができます。

もし WordPress、テーマ、プラグインのバージョンが低すぎる場合PHP 7.3でエラーが発生する可能性があります。 そのような場合のテーマ、プラグイン、 WordPress コアの両方を最新のバージョンにアップデートすると、問題が解決されています。

おわりに

以上で Cafe24でphpMyAdminをインストールして接続するときに接続が切断しながら「要求の処理エラーのエラーコード:200」エラーが発生した場合に対処する方法について説明しました。 現在の最新バージョンのPHPは8.0です。 PHP 8.0を適用すると、理論上の速度が向上されます。 このブログは、現在のPHP 8.0を適用した状態です。

参照



コメントを残す

コメント