ベストセラー人気 WordPress テーマTop 30 詳細

10年のPHP-FPMローカル権限上昇の脆弱性を発見

Last Updated:2021年11月8日| コメントを残す
  • Naver ブログを共有する
  • Naver バンドに共有する
  • Facebook 共有する
  • Twitter 共有する
  • 카카오스토리공유하기
10年のPHP-FPMローカル権限上昇の脆弱性を発見

セキュリティの専門家がPHPに影響を与えるPHP-FPMのローカル特権の昇格の脆弱性のために、多くの何百万ものウェブサイトが危険にさらされる可能性があると警告しました。 この脆弱性は、ルートFPMプロセスが共有メモリ(SHM)にあるポインタを使用して任意の場所に読み書きできるようにし、www-dataからrootへの特権の昇格を可能にします。 この脆弱性は10年間存在してきたそうです。

10年後のPHP-FPMローカル特権の昇格の脆弱性の発見 - 構成でPHP-FPMが有効になっているシステムにのみ影響する

PHPは WordPress(WordPress)、ドルパル(Drupal)、ズーラ(Joomla)などを含むウェブサイトの78.4%に使用されています。 海外のLinux関連ブログに10年間存在していたPHP-FPMで発見された脆弱性に関する記事が上がってきました(」10-Year-Old PHP-FPM Local Privilege Escalation Vulnerability Discovered"参照)。

このセキュリティ問題の影響を受ける PHP バージョンは、7.3.x ~ 7.3.31、7.4x ~ 7.4.25 未満、8.0.x ~ 8.0.12 未満でデフォルト root で実行する FPM daemon プロセスと、より低い特権のユーザーとして実行するチャイルドワーカープロセスでPHP-FPM SAPIを実行すると問題になると言われています。

脆弱なPHPバージョンを使用しているかどうか疑問に思う場合:ApacheとPHPを使用している場合は、PHP-FPMを使用している可能性があります。 確実にするには、ApacheがPHPをモジュールまたはPHP-FPMを介して実行しているかどうかをサーバーで確認する必要があります。 ただし、NGINXとPHPを使用している場合は、PHP-FPMを使用しているため脆弱です。

幸い、この脆弱性はPHPバージョン8.0.12および7.4.25で修正されました。 脆弱性が存在するバージョンのPHP-FPMを実行している場合は、すぐに対応するリリースブランチで最も高いバージョンにアップデートしてください。

ちなみに、2021年7月基準で世界中のPHPバージョン別シェアを見てみると、PHP 7.4が46.8%で最も多く使われており、PHP 7.3が19.2%、PHP 8.0が14.7%とその後に続いています。

2021年のPHPバージョンシェア

WordPressでPHPのバージョンを確認する

WordPressは 管理者ページ > ツール > サイトの健康 > 情報 > サーバー セクションでPHPのバージョンを確認できます。

私はチェックしてみるとPHP 8.0.12バージョンでバグが修正されたバージョンですね。

WordPress PHPのバージョンを確認

最後に、

Linuxコミュニティを巡るより、PHP-FPMに存在する脆弱性発見のニュースに触れ、このブログに紹介してみました。 この脆弱性は、2021年10月21日にPHP.NETの人々によってパッチになったと言われています。

WordPressを実行している場合は、可能な限りPHP 7.4以降を使用することをお勧めします。 PHP 7.3 は、2021 年 12 月 6 日までセキュリティサポートが提供されるとします。 低PHPバージョンを使用する場合は、最新 WordPressがインストールされていない、または更新されない可能性があり、古いバージョンの WordPressを使用すると、セキュリティに問題がある可能性があります。

特権昇格の脆弱性は、管理者が意図した程度よりも多くの特権、システムやアプリケーションへのアクセスを高めることができるセキュリティ上の問題で、完全なエクスプロイトチェーンを作成するために必要ですが、SS( Severity Scoreが低く、開発者や防御者が見落とすことが多いため、攻撃者に価値のある脆弱性になるそうです(」権限の上昇が攻撃者にとって重要な脆弱性である理由"参照)。

参照



コメントを残す

コメント