いよいよPHP 7.2を適用しました

2

현재 WordPressの推奨PHPのバージョンは、7.2以上です。

  • PHP 7.2以上
  • MySQL 5.6以上またはMariaDB 10.0以上
  • NginxやApache with mod_rewrite module
  • HTTPSサポート

このブログは利用されている Bluehost VPS에서는 PHP 7.2를 이용할 수 있습니다. 하지만 2018년 1월 말에 PHP 7.2를 적용하니 에러가 발생하여 PHP 7.1을 유지하다가 지난 주에 PHP 7.2를 다시 적용해보니 문제 없이 작동하네요. (2019년 기준으로 VPS에서는 PHP 7.3까지 적용이 가능합니다.)

PHPのバージョンを確認してみるPHP 7.2.3に表示なりますね。

PHP 7.2.3

Bluehost 共有ホスティングでは、PHPのバージョンを変更する方法は次の記事を参考にしてください。

Bluehost VPSの場合WHMにログインしてPHP 7.2を構築した後、PHP 7.2バージョンを選択することができます。

PHP 7.2が構築されていない場合 WHM> EasyApache4に接続して Currently Installed PackagesカスタマイズしてPHP 7.2パッケージを追加することができます。

PHP 7.2インストールする

PHP 7.2をインストールした後は、 MultiPHP INI EditorでのPHP環境の設定値を変更して与えるようにします。

PHPのバージョンを変更する

私は次のように設定しました。

そして MultiPHPマネージャでPHPのバージョンを変更することができます。

低ホスティングの場合、まだ多くのホスティングからPHP 7.0まで提供しており、場合によってはPHP 7.1を提供するところもあります。 (古代ディで、最近PHP 7.0とPHP 7.1のサポートが追加されました。 "韓国語のサポートが提供されている海外のホスティング - 古代ディ(GoDaddy)"参照)

해외 호스팅 중 하나인 Siteground에서는 PHP 7.27.3까지 이용이 가능합니다. SiteGroundで、特にフォルダごとPHPのバージョンを適用することができて便利にPHPのバージョンを適用することができます。

SiteGroundは、比較的安定して速度も速い方で使用するにも便利な方です。 歌声雨良いホスティングをしたい場合は Bluehost 共有ホスティングを考慮してみることができます。 安価にまともなリソースを利用することができます。 安定性と速度が重要な場合 Sitegroundはより良いオプションです。

※ 2019년 현재 VPS에서는 PHP 7.3까지, 공유호스팅의 경우 PHP 7.2까지 적용 가능합니다. "cPanelとWHMバージョンのアップグレード方法」を参考にしてみてください。

2のコメント

  1. こんにちは。 昨年からブログよく見ています。 ありがとうございます。 私もスピードとテーマ、プラグインの使用の制限のために WordPress 7バージョンにアップグレードしたいのですが気になることがあってずにいます。 Cafe24を使用中なのにアップグレードをするには、サーバーとdbが変わるそうです。 だから既存の最適化された文が初期化なるかと思っ懸念されます。 その部分は、問題なかったのか疑問に思っています。

    • こんにちは?

      バックアップをよく受けおかとPHP 7にアップグレードすることが速度の面でいいようです。

      PHP 5.x台からPHP 7に変更速度が確実に速くなるでしょう。

      もし問題がされると、バックアップ受けたバックアップを利用して、元に戻すことができます。

      Bluehostナ SiteGround など海外のホスティングでは、PHPのバージョンを簡単に変更することができますが、 Cafe24の場合は少し面倒です。

コメントを残す

あなたのコメントを入力してください!
あなたの名前をここに入力してください