[WordPress] Avadaで「Parse error:syntax error、unexpected T_PAAMAYIM_NEKUDOTAYIM「エラーが発生した場合 - WordPress 情報パッケージ
인기 WordPress テーマブルフセール 詳細

[WordPress] Avadaで「Parse error:syntax error、unexpected T_PAAMAYIM_NEKUDOTAYIM「エラーが発生した場合

Last Updated:2022年8月2日| 4のコメント
  • Naver ブログを共有する
  • Naver バンドに共有する
  • Facebook 共有する
  • Twitter 共有する
  • 카카오스토리공유하기

최근 Avada(Avada) 5.0をインストールまたは更新すると、次のようなエラーが発生する問題が発生することがあります。

Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/XXXXX/public_html/wp-content/themes/Avada/ includes / class-avada-product-registration.php on line 167

Parse error: syntax error, unexpected... エラーは主に PHP バージョンが低いために発生します。 2022年8月現在のPHPの最新バージョンは PHP 8.1推奨PHPバージョンはPHP 7.4以降です。 可能な限り7.4以上のPHPバージョンを使用することが望ましいです。 このエラーが発生した場合は、1)サイト全体をバックアップし、2)PHPバージョンをアップグレードし、3) WordPress、テーマ、プラグインをすべて最新バージョンにアップデートし、4) 長い間アップデートができないテーマやプラグインは削除してください。

Avadaで「Parse error:syntax error、unexpected T_PAAMAYIM_NEKUDOTAYIM「エラーが発生した場合

上記のエラーは、 Avada 5.0の既知のバグと呼ばれます。 まず、最新の Avada バージョンにアップデートすると、問題が解決されることがあります。

それでも問題が解決しない場合は、現在使用しているPHPのバージョンを確認してください。 主に5.2のバージョンで問題が発生して、たまに5.4バージョンでも発生するとします。 5.6以降のバージョンでPHPのバージョンをアップグレードと、問題が解決されています。

Avada 仕様

追加: Avadaのシステム要件は、 WordPress 4.6以上、PHP 5.6以降は、MySQL 5.6以上(2016年10月16日現在)です。 仕様に準拠していることを確認して、システム要件を満たして、最新の AVADA バージョンをインストールしても問題が発生した場合 Avada サポートに連絡して、問題の解決を試してみてください。

参考までに、既存 Avada サイトを新しい5.0どおりに更新する場合は、必ずバックアップを取るおいてください。 場合によっては、深刻な問題が発生する可能性があります。 Avadaが5.0に更新されFusion Builderが新しくなりました。 このため、新しいバージョンに更新時に既存ショートコードなどを新バージョンに合わせて変換する過程を経ることになります。 この過程でエラーが発生する可能性があります。 この場合には、前のバージョンに復元する必要があります。

Avada 5.0にアップデートしてみるとFusion Builderが今パリッに動作することを感じることができました。 以前のバージョンでは、フュージョン・ビルダーでロードがあって重い感じがあったが、新しいバージョンでは、そのような感じがたくさん消えた。

Avada 5.0で導入された新しいFusion Builder
Avada 5.0で導入された新しいFusion Builder

WordPress テーマの中から不動の販売1位を維持している Avadaは、特に多くのテーマオプションを提供して、初心者でも簡単に使用できる利点があります。

メモ:



4のコメント

コメント

  1. MySQL 5.6は Cafe24でサポートされていないが、もしかしたらお勧め受けるホスティングでしょうか?

    応答
    • こんにちは?

      ブログを訪問していただきありがとうございます。

      Cafe24でPHP 7に更新ください。 その後、 Avadaが正常に動作します。

      ちなみに私は Bluehost VPS(www.thewordcracker.com/go/bluehost/ )を使用していますが、PHPバージョンは5.6です。 Bluehostもそれなり大丈夫そうです。 同じWebホスティングサーバーの https://avada.co.kr/ サイトに現在 Avada 5.6がインストールされています。

      Bluehostの場合、低コスト無制限のディスク容量/無制限のトラフィックが、不安定である評における推奨いたしませアンゴヨは、もし Bluehostを考慮すれば、VPS以上を選択すると、まともなようです( https://www.thewordcracker.com/miscellaneous/introducing-bluehost/ を参照)。

      まずはPHPのバージョンを7.0通り高めテストしてみません?

      応答
  2. ホスティング会社が Cafe24 光アウトバーン一般に数日前に変更しました。 avadaは5.0.1バージョンスリップ。 アドバイスお願いします。 ^^

    応答
    • こんにちは?

      Avada テーマの要求仕様がPHP 5.6以上です。

      使用するには Avada、please make sure you are running WordPress 4.6 or higher、PHP 5.6 or higher、and MySQL 5.6 or higher

      現在のホスティングサーバーのPHPのバージョンを確認してください。

      応答

カフェで WordPress 情報を共有できます。

ありがとうございます!